Mikrotik cihazlarımızın üzerinde URL, kelime,uzantı vb. kelimeleri engelleyebiliriz. Buna neden ihtiyaç duyma nedeniz ise ofis yada ev ağınızdan birden fazla bilgisayara sahip iseniz girilmesini istemediğiniz siteler yada indirilmesini istemediğiniz uzantıları engelleyebiliriz ve bu şekilde ağınızı kontrol edebiliriz. Unutulmadan Yeni çıkan 5651 Yasası gereği toplu intenet kullanımı sağlayan firmaların tüm kullanıcıların erişimlerini kaydetmesi yasal olarak zorunludur. 4 Mayıs 2007 tarihinde kabul edilen yasa ve parallinde yayınlanan bu yönetmelikler ile kurum ve kuruluşlarİç IP adres dağıtım loglarının toplanması (DHCP Logları) Kullanıcıların web erişim olaylarının toplanması kullanıcıların web erişimlerinde içerik bazlı filtre uygulanması (URL Filtering) Oluşan verilerin bütünlük değerlerinin (hash) zaman damgası ile saklanması ve gizliliğinin temin edilmesi yükümlülüklerini yerine getirmek zorundadır. Log kayıtlarınında tutmak isterseniz bu konu hakkında ilerde sunmak istediğim makalemde okuyabilirsiniz.

NOT: Eğer orta ve büyük ağınız varsa Web Proxy uygulaması için seçilen donanımlara dikkat edilmesi gerekir, dikkat etmediğinizde ağınızda aşırı yavaşlama ve tıkanmalar meydana gelecektir. Tavsiye edebileceğim PC/X86 bir kasa kullanarak webproxy kullanmanızdır.

Şimdi konumuza geri dönemlim isterseniz Winbox üzerinden grafik arayüzünü kullanarak yada yine aynı şekilde winbox üzerinden New terminal üzerinden komutlarımızı yazarakta bu işlemleri gerçekleştirebiliriz. Benim anlamatmak istediğim ise Terminal üzerinden işlemlerimizi gerçekleştireceğiz.

Winbox açtıktan sonra gerekli bilgilerinizi girdik ve bağlandıktan sonra sol menude bulunan “New Terminal” tıkladıktan sonra terminal penceresi açılacaktır. Tüm komutlarımızı bu pencere gerçekleştireceğiz. NOT: Bu işlemleri Telnet yada SSH üzerinde de gerçekleştirebilirisiniz.

ilk komudumuzda Web Proxy aktif hale getirelim.

/ip proxy set enabled=yes always-from-cache=no cache-administrator=Webmaster cache-hit-dscp=4 cache-on-disk=no max-cache-size=none max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=no src-address=0.0.0.0

Yukarıda vermiş olduğum komutu terminal ekranına yazınız, yazma sırasında Örnek:/ip pr dediğimizde otomatik olarak geri kalan satırı yazacaktır ve bu işlemle komutları daha hızlı yazma işlemleri gerçekleştirebilirsiniz. Bu işlemleri yaptıktan sonra son satırıda yazdıktan sonra Enter tuşuna bastığımızda otomatik olarak işlem gerçekleşmiş olacaktır. Bu işlemlerinin doğruluğunu görmek için aşağıdaki komutları girebilirsiniz.

/ip proxy print

Yukarıda komudu girdikten sonra terminalde aşağıdaki şekilde karşınıza görünecektir.

[admin@xxxx] >> /ip proxy print
enabled: yes
src-address: 0.0.0.0
port: 8080
parent-proxy: 0.0.0.0
parent-proxy-port: 0
cache-administrator: Webmaster
max-cache-size: none
cache-on-disk: no
max-client-connections: 600
max-server-connections: 600
max-fresh-time: 3d
serialize-connections: no
always-from-cache: no
cache-hit-dscp: 4
cache-drive: system
[admin@xxxx] >>

Bu işlemlerden sonra Firewall üzerinden Web Proxy için NAT ekleyelim. bu işlem için aşağıdaki komutları terminal ekranına yazınız.

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp to-ports=8080

Yukarıdaki komutları girdikten sonra yaptığımız işlemin gerçekleştiğini kontrol etmek için

/ip firewall nat print

Yukarı komudu girdikten sonra satırın eklendiğini görebilirsiniz.

bu işlemlerden sonra engellemek istediğiniz URL,uzantı yada kelimeyi Web Proxy ekliyelim. Bu işlem için sizler için örnek vereceğim.

/ip proxy access add action=deny disabled=yes path=:sex/ip proxy access add action=deny disabled=yes dst-host=*gtunnel.com*

Yukarıdaki komutları yazarakta engelmek istediğiniz kelimeleri :sex yada gtunnel.com yazılarını değiştirerek ekliyebilirisiniz.

Web-Proxy eğer log tutmak isterseniz disk üzerine yada memory yada uzaktaki bilgisayar kayıt altında tutabilirsiniz. Bu işlemleri gerçekleştirebilmek için aşağıdaki komutları terminal ekranına yazınız.

/system logging add action=disk topics=web-proxy

bu işlem yaptıktan sonra eğer disk üzerine kayıt etmek istiyorsanız unutmayın yüksek kapasitede eğer bir hardisk kullanırsanız 1 yada 2 yıllık kayıtlarınızı tutabilirsiniz.

Son olarak Web Proxy üzerinde engellemiş kelimeleri giriş yaptığımızda karşımıza Mikrotik Web Proxy için hata HTML dosyası bulunmaktadır bu hata ekranı kendinize uygun olarak düzenleyebilirsiniz. Bu HTML dosyasını Winbox üzerinde sol tarafta bulunan menu üzerinden Files Bölümünden Web Proxy klasörü altında error.html dosyasıdır. Bu HTML dosyasını bilgisayarınız üzerinde HTML bilginiz var ise kendinize uygun olarak düzenleyebilirsiniz

No Comment

You can post first response comment.

Leave A Comment

Please enter your name. Please enter an valid email address. Please enter a message.